Difference between revisions of "util-vserver:Development Debian Packages"

From Linux-VServer

Jump to: navigation, search
(Help using the repos)
Line 45: Line 45:
== Help using the repos ==
== Help using the repos ==
Documentation is at http://kernels.bristolwireless.net/
Documentation is at http://repo.psand.net/info/

Revision as of 19:29, 19 April 2010


repo.psand.net repository

This page details the util-vserver related contents of the repository at http://repo.psand.net/


The repository has is regularly updated with new kernels and the new Debian packages for the vs2.3.x (the Linux-Vserver development branch). At time of writing (01/04/2010) the repository contains the following package for Debian Lenny (i386 and amd64 architectures):

  • a number of 2.6.31 series kernels, the latest is linux-image-
  • two 2.6.33 series kernels, the latest being linux-image- (AMD64 only)
  • a metapackage which will automatically update you to the latest 2.6.31 release, the package is named linux-image-vserver-2.6.31-beng

Util-Vserver packages

Note from Ghislain: If anyone on the list has some debian package knowledge to help me separate one source into several binary packages please contact me gadnet =at= to help i would like to make de devl and legacy package separated from the main one.

There are two flavours of package for the development version of util-vserver:

the util-vserver-basic-debian uses:

       ./configure $(CROSS)    --prefix=/usr \
                               --sysconfdir=/etc \
                               --localstatedir=/var \
                               --mandir=/usr/share/man \
                               --infodir=/usr/share/info \
                               --with-initrddir=/etc/vservers/init.d \
                               --with-vrootdir=/var/lib/vservers \

the util-vserver-basic uses:

       ./configure $(CROSS)    --prefix=/usr/local \
                               --with-initrddir=/usr/local/etc/vservers/init.d \
                               --enable-dietlibc \

Choose the '-basic' if you upgrade from source, choose the '-debian' if you upgrade from debian packages. As allways those packages comes with no warrant other than that we made them for us and provide tehm to the community in hope they help so they work for us on production server so they should be quite safe. Report issue with them on the vserver list if you find any so we can correct them.

I use them on several servers without issues on Debian Lenny. The version in the repository is 0.30.216-pre2882.

Help using the repos

Documentation is at http://repo.psand.net/info/

Personal tools