Problematic Programs

From Linux-VServer

Revision as of 17:43, 6 March 2007 by (Talk)

Jump to: navigation, search

Some programs do things that might work on a normal host but not inside a V-Server. This is often not a fault of V-Server itself, the programs are doing automagic things which fail and no proper error handling is done. Also sometimes the actions need special rights which are not permitted by default in V-Servers. Allowing CAPs is often not necessary since those special CAPs are only required once (e.g. when the program initializes the directories/settings/whatever).


OpenGroupware Apache Module

If your V-Server doesn't have access to localhost, then the connection to the OpenGroupware server will fail with a "Internal Server Error". The apache module for OpenGroupware called mod_ngobjweb uses a hardcoded "" IP address in the source (handler.c line 339), this line you need to change to the IP address that should be used (the IP of the V-Server that runs the OpenGroupware? server)

Hylafax (with CAPI)

If you want to run hylafax in a V-Server, you will get a CAP and device problem which can be easily solved. First you need your capi20 devices in your V-Server, which can't be created by ./MAKEDEV (requires special CAPs) so copy the devices into the V-Server, like this (command run on the host):
cp -aR /dev/capi* /vservers/your_vserver/dev
Now hylafax can access your CAPI ISDN card but will exit after a few seconds, the problem is it tries to create a /dev/null nod in the hylafax chroot. This fails because of missing CAPs, so lets help hylafax again with copying the nod into the hylafax chroot in the V-Server. Like this (command run on the host):
cp -aR /dev/null /vservers/your_vserver/var/spool/hylafax/dev

Allright, now hylafax should have CAPI access and run properly.

Links inside screen inside a V-Server

Don't know why, but links crashes systematically being inside a screen session inside a V-Server started outside a V-Server. (please elaborate!)

screen inside a VServer

[root@ge root]# vserver zoe enter

zoe:/# screen
Cannot open your terminal '/dev/pts/5' - please check.

zoe:/# strace screen 
stat64("/dev/pts/5", {st_mode=S_IFCHR|0620, st_rdev=makedev(136, 5), ...}) = 0
open("/dev/pts/5", O_RDWR|O_NONBLOCK)   = -1 EACCES (Permission denied)

is neither a bug nor an issue with screen, it just shows that a vserver context is not allowed to mess with host terminals. either use ssh/telnet to reach the 'guest' or start the screen session before you do the 'enter' (i.e. on the host)

OpenLDAP Startup

slapd needs name resolution available in order to start up, otherwise it appears to hang. Make sure you have working DNS (or whatever) available to your vserver before starting one with slapd. This behavior is confirmed in my setup, no confirmation from others yet. My Setup: vservers all bind to an interface on a DMZ-like network segment, BIND runs on a vserver. slapd would hang at startup if the BIND vserver had not been started first.


Bind's rndc has a hardcoded somewhere so any command to rndc will fail with connection refused. You should have a reachable localhost address defined in /etc/hosts and then you can use
rndc -s localhost
command. You can make a rndc.conf and set the default-server option, like that the '-s localhost' isn't necessary.


Since some version of Asterisk (at least since 1.0.2), it will not run anymore. On start it fails with: "Unable to set high priority". This can be solved by allowing CAP_SYS_NICE for that V-Server. You can also not run Asterisk with the realtime priority - Just pass the '-p' command ligne argument to disable the read-time priority. Good doc on setting up Asterisk devices in the vserver: (additional documentation for Asterisk 1.4 installation available here:


Fails because of writing to /proc (requires patch) TODO: write me


Oplocks don't work as smbd insists on receiving break requests from Just patch source/smbd/oplock.c (commenting paranoid code)

+++ oplock.c.orig       2005-02-14 14:27:51.000000000 +0200
--- oplock.c    2005-02-02 12:27:50.000000000 +0200
@@ -181,14 +181,12 @@
                return False;

+#if 0
     /* Validate message from address (must be localhost). */
        if(from.sin_addr.s_addr != htonl(INADDR_LOOPBACK)) {
                DEBUG(0,("receive_local_message: invalid 'from' address \
 (was %lx should be\n", (long)from.sin_addr.s_addr));
                return False;

        /* Setup the message header */

or if you don't want to patch the samba source code you can disable oplock in Samba and it will work too!

Just put the following in your smb.conf:

kernel oplocks = no
oplocks = no

Note: The Vserver using Samba should also listen on the broadcast address. Thereby you will not be able to have two samba servers in the same net (on the same broadcast).

Samba from Debian 3.1

The samba deb in sarge (3.1) provided file sharing. The only oddity observed is that the vserver guest running samba did not appear in a windows box's 'My Network Places'

Use a WINS server. The SMB browsing protocol relies heavily on broadcasts on the local net, which are problematic with vservers. WINS resolution on the other hand is unicast and works flawlessly under vserver.

Samba printer and file server with cups

Samba runs correctly in a Mandriva (Mdk) 10.1 Vserver, (Apart from the above oplock problem ?).First, edit your /etc/sysconfig/network file, and set networking to yes (This will solve problems for other services !):

# cat /etc/sysconfig/network

Some more tweaking is needeed in /etc/smb.conf

# cat /etc/smb.conf
  interfaces =

But if you're using Samba + Cups to provide printing for Windows clients, AND if you want to use the Point and Print feature, there is more: In the [printers] section of your smb.conf, you should have the use client drivers directive set to no, or the driver upload procedure will fail !

# cat /etc/smb.conf
  use client driver = no

So, here is a full smb.conf file:

# cat /etc/samba/smb.conf | awk '!/^$/ && !/^\s*(#|;)/ {print $0}'
   workgroup = MYDOMAIN
   netbios name = MYHOSTNAME
   server string = MYCOMMENT (Samba %v)
   printcap name = cups
   load printers = yes
   printing = cups
   printer admin = @adm
   log file = /var/log/samba/log.%m
   max log size = 50
   map to guest = bad user
   security = domain
   password server = *
   encrypt passwords = yes
   smb passwd file = /etc/samba/smbpasswd
   username map = /etc/samba/smbusers
   idmap uid = 10000-20000
   idmap gid = 10000-20000
   socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
   wins server = MYWINSIP
   dns proxy = no
   # for french users:
   dos charset = 850
   unix charset = ISO8859-1
   comment = Home Directories
   browseable = no
   writable = no
   comment = All Printers
   path = /var/spool/samba
   browseable = no
   guest ok = no
   writable = no
   printable = yes
   create mode = 0700
   print command = lpr-cups -P %p -o raw %s -r   # using client side printer drivers.
   use client driver = no
   path = /var/lib/samba/printers
   browseable = yes
   write list = @adm root
   guest ok = yes
   inherit permissions = yes

...And a working smbusers:

# Unix_name = SMB_name1 SMB_name2 ...
root = administrator MYDOMAIN\administrator
nobody = guest pcguest smbguest

Cups print server

Symptoms: The Cups init script exits with:

Starting CUPS printing system: cupsd: Child exited with status 98!

And the logs (/var/log/cups/error_log) show:

E [date:hour...] StartListening: Unable to bind socket for address - Address already in use.

...Or something like this.

With a correct "cupsd.conf file" (Tested version 1.1.21-0.rc1.7mdk, on Mandrake 10.1 - Now Mandriva), it works; All we need is to remove references to or localhost from the file, as well as correctly unsetting the Listen directive:

LogLevel info
TempDir /var/spool/cups/tmp
# No 'Listen' directive !
Port 631
BrowseAddress @LOCAL
BrowseDeny All
BrowseAllow @LOCAL
BrowseOrder deny,allow
<Location />
  Order Deny,Allow
  Deny From All
  Allow From @LOCAL
<Location /admin>
  AuthType Basic
  AuthClass System
  Order Deny,Allow
  Deny From All
# Or
  Allow From @LOCAL

Then you'll need to modify the /etc/init.d/cups script, to comment any section referring to lookup and configuration. This section exists at least on Mandrake 10.1, and is pretty long (Lines 35 to 55 and/or 79), and additionnaly four "else...if" lines must be commented far below (Lines 161 to 164) !

Remember to stop any Cupsd running in the host server, or to start it via a wrapper /etc/init.d/v_cups script:

# chkconfig: 2345 15 60
# description: Wrapper to start cups bound to a single IP
exec $USR_LIB_VSERVER/vsysvwrapper cups $*

Do not forget to give a password to the root user, if you want to ba able to manage your printers from the web interface (http://yourcupsvserver:631)!

# passwd root

If you use Mandriva 10.1 (And maybe some other distros), you’ll need to add the printers drivers for Cups, and reload it:

# urpmi --root /vservers/yourcupsvserver/ cups-drivers
# /etc/init.d/cups reload

…It added 67 Mb of packages for me.

Then use /etc/init.d/v_cups (re)start to launch Cups on the host server. You will now be able to make Cupsd start in the vserver , but more tweaking on the ACLs may be necessary to avoid authentification problems...

Bind9 on Debian GNU/Linux Woody (3.0), Sarge (3.1), Etch (4.0)

named provided by the bind9 binary packages fails to start because it is compiled with CAPs option.

The debian way is to build** your own package without CAPs:

su -
cd /usr/src
apt-get build-dep bind9
apt-get source bind9
cd bind9-x.x.x
vi debian/rules

Insert the following line after "./configure --prefix=/usr \":

--disable-linux-caps \ 

On a NPTL-enabled system you alse have to replace

--enable-threads \


--disable-threads \

or bind might refuse to run with an other user than root.

Save the file and go ahead with compiling/installing:

dpkg -i ../bind9-x.x.x.deb
echo "bind9 hold" | dpkg --set-selections

The last line is to set the package "on hold", so it is not touched by the update process. you have to take care of security holes by yourself now!

The Xs in "bind9-x.x.x" denote the version number of bind9. Alternatively you can allow the CAP_SYS_RESOURCE for that V-Server. The best way would be to fix bind, which is somehow broken when it comes to capabilities. Daniel Hokka Zakrisson repaired it. His patch is to be found here:

[bind-9.3.2-caps-when-available.patch] need patch url please

So, if you recompile, it would be the cleanest way to apply that patch. Thanks Daniel! It would be also nice, if someone submits that patch to the bind people or maybe to your distribution's package maintainers in the first step.

Get my vserver-guest-ready Debian bind9 package for Debian Sid guests. Feedback welcome:

Problems getting this to work in an x86_64 vserver. Any hints? From what I can tell from stracing, turning off threads doesn't fix everything related to it. It also caused a juicy Ksymoops.

Zimbra Mail

Zimbra is many applications (including Postfix and MySQL? and OpenLDAP? and more) which try to take over the interfaces, and depend a lot on binding from - it is not hard to change, but there is a couple of tricks - it is documented here -


won't start with no error message.

"xine --verbose" shows this.

ERROR: Could not determine network interfaces, you must use a interfaces config line

This happens if you have the plugin. Delete it and everything is fine. issues

I had problems with an application that wanted me to access it on and AS to be able to do its configuration. A simple tweak solved the problem. I renamed the default interface directory "0" in /etc/vservers/server/interfaces to "1" and created interface 0 as :

dev lo 
name lo 

now interface "1" is the default created interface by the vserver build script with a local adress like and interface "0" is the loopback. I can now telnet on and it sees that im connecting to from

Compiling nagios-1.4 within a vserver requires this, otherwise it hangs during the configure with "checking for ICMP ping syntax..."


Does not want to start. TODO: add more information.


Postfix 2.1.5 (Debian Sarge)

On a vserver with two interfaces (lo and eth0), and a postfix 2.1.5 listening on lo, postfix can't send emails : "Invalid argument"... Setting smtp_bind_address ( to the external address solves the issue.

Postfix Policy Daemon

Running a Debian 3.1 Sarge with Backports I have several issues with the postfix-policyd because it wants to set the rlimits.

Log returns:

cannot set rlimit: Operation not permitted

Strace tells us:

setrlimit(RLIMIT_NOFILE, {rlim_cur=4097, rlim_max=4097}) = -1 EPERM (Operation not permitted)

Output on the Host

# ulimit -Ha
-n: file descriptors           1024

Thats too little...


The App has again a build in need to use CAP_SYS_RESOURCE (which is bad (tm)) so in the guest do:

# ulimit -HS -n 8192
# ulimit -Ha
.. shows us now the correct 8192 instead of 1024.

# vserver $yourVserverName restart
# vserver $yourVserverName enter

$yourVserverName # ulimit -Ha
-n: file descriptors           8192

Everything should be fine now !


When starting dhcpd you are quite likely to see

Open a socket for LPF: Operation not permitted

Dhcpd needs raw network access to work, and to grant your vserver such privileges you need to do:

# echo NET_RAW >> /etc/vservers/yourvserver/bcapabilities

And restart your vserver. Keep in mind that it will lower security because it allows programs to forge packets.

Personal tools